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Comic Life Workshop 

Libraries 
The Libraries tab is divided into two sections. The expandable top section holds templates you can use to 

quickly layout panels on a page. The lower section shows your My Pictures folders, your Windows folders in 

the Explorer tab, live video feed from your video camera (if one is available) on the Capture tab.  

Choosing a template 
To use one of the templates you can drag and drop it onto a blank page or simply double-click it. If the current 

page is empty (has no elements of any kind on it) the panels from the template are added to the current page. 

Otherwise, a new page is created directly after the current page and the panels are added to that. In either case 

the panels are automatically stretched to fit the dimensions of the page.  

Adding images 
Your My Pictures folder is displayed below the template area — or you can also choose to browse your 

computer's contents via Explorer.  

 Click and drag an image from the album or folder and release the mouse button when your cursor is 

within the panel where you want the photo to go.  

 Note: When an image is dropped on a panel the image 

becomes attached to the background of a panel.  

 When the panel is moved the image moves with it. If you 

want to add another image to a panel, rather than replace it, hold down 'Alt' while dragging and dropping 

your additional image.  

 If you have a video camera connected to your computer you can grab still-images from it directly and 

drop them onto your comic. You can drag and drop from the live video feed:  

Adding Balloons 
Drag a Balloon from any of the Balloon wells at the bottom of the window and drop it onto a panel.  

1. 2. 3.  

 A Balloon is created on the panel and ready to be edited. Enter whatever you want and then either click 

outside the text area or hit the "enter" key on your keyboard to save the new text.  

 Comic Life lets all balloons hang over the edge. You can enable the clipping behavior for a particular 

element by selecting it then choosing the "Arrange->Clip" menu item. To enable clipping as the default 

behavior, check the "Clip new non-image elements to panels" check-box in the Options. 

Adding Captions: Drag and drop them on the panels and add the text.  

Lettering:To add a Lettering element, drag and drop from the Lettering well onto a panel. A window will 
now appear where you can enter your text. You can also change the font at this point too.  

 
 

Making Changes: Many of the changes can be made by directly interacting with the elements on the page for 

example moving, resizing and rotating.  
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Selecting Elements: Elements can be selected by clicking on them. Typically one element at a time will be 

selected — when you click on a different element any other elements will be deselected. To select more than 

one element: hold down the "Alt" key while clicking. You can also select groups of items by dragging a 

selection box around the elements. To select all the elements on a page use the "Edit->Select All" menu item.  

 

Resizing Elements: Only one element at a time can be resized. Select the desired element and use the handles 

bordering the element to adjust its size.  

 

Rotating Elements: Two types of elements can be rotated: image elements and Lettering elements. To limit the 

rotation to 90° angles hold down the "shift" key while dragging. The element will snap to the nearest 90° angle.  

 

Deleting Elements: Select the element and hit the "delete" key or choose the "Edit->Delete" menu item.  

 

Reordering Elements: Sometime elements will be behind or in front of other elements on the page. You can 

use the Arrange menu to change this ordering. Use "Send to Back" to move an element to back of the display 

order. Use "Bring to Front" to bring an element to the front.  

 

Editing Text: Some elements on the page are containers for text (Captions, Balloons and Lettering) — to edit 

the text in these containers double click on one of them or hit the "Enter" key if the element is selected. For 

Captions and Balloons the text in the container becomes editable and the entire contents are selected. Start 

typing to replace the selected text or click at the desired character position to make minor changes. To save your 

changes either click outside of the editing area or hit the "enter" key on your keyboard. For Lettering elements 

(this requires a double click of the mouse, "Enter" will not work) a dialog opens with the editable text — make 

the necessary changes in the dialog and click on the "Place Lettering" button to update the element on the page.  

 

Details: 

The Details section gives you access to extra controls for different elements. If no elements are selected on a 

page then the controls for the page itself are displayed.  

The Details area is split between Attributes controls and Style controls.  

 Attribute controls provide access to special features of each type of element.  

 Style controls handle characteristics such as fill colors and line widths. 

Styles: Styles let you quickly make uniform changes to multiple elements in your comic.                              
To change the style of an element, choose from the Style popup menu, or experiment until you create a 
style you like. If you have made a variation to the existing style, then a pencil appears next to the style 
name. If you don't like your changes, press the Revert button to go back to the original style. If you 
created a new style and want to apply it to a number of elements simultaneously you can use "Edit->Copy 
Style" and "Edit->Paste Style".  

Undo: Comic Life provides full support for undo — practically any operation can be immediately undone 
letting you explore its features.  

A Note on Page Sizes: By default Comic Life is configured to a page size that's suitable for the web. You 
can change the page size by choosing the "File-> Page Format..." menu and picking a different Page Size in 
the popup menu.  
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Layout options: To create a page with a regular grid layout where each panel is the same size as the others use 

the "Page-> New Page with Grid Layout...". A dialog appears where you 

can specify the number of rows and columns for the page and a gutter.  

Note: The gutter is the spacing between the cells and the margin. 

Enter the rows, columns and gutter values you desire and 

click the OK button. A new page is created after the current 

page.  

 

 

Template layout: Page templates provide many irregular 

page layouts which you can view in the Page Template browser. 

 

 

Custom layout: Comic Life also lets you design a completely custom layout by placing panels directly on the 

page and adjusting them to suit your needs.  

 

Adding pages: There are four ways to create a new page:                                                                                     

 

Blank Page: To create a new blank page; use the "Page-> New Blank Page" menu item. A blank page is added 

after the current page.                                                                                                                                                                 

 

Page with grid layout: Use the "Page-> New Page with Grid Layout..." option.                                                     

 

Page from a template: At any point you can drag a page template on top of the current page being edited and 

create a new page with that template.                                                                                                                             

 

Page from current page: You can easily create a new page of panels based upon the layout of the current page. 

Choose "Page-> New Page like Current Page".  

Deleting pages: To delete a page make sure it is displayed in the edit area either by selecting it in the 
organizer or by using the "View-> Next Page" or "View-> Previous Page" menu items. Once the page is 
selected choose the "Page-> Delete Page" menu item. A confirmation dialog is displayed. Clicking "Yes" 
will delete the page.  

Reorganizing pages: Change the order of pages in the organizer by dragging pages up and down.  

Page Control: The "+" button adds a new blank page after the current page. The "-" button deletes the 
current page (after you have confirmed the action in a dialog). Clicking on the button with a gear reveals 
the context menu for working with pages.  

These actions are also available in the Page menu on the menu bar. Make Text on Page Bigger or Smaller 

increases or decreases the size of all the text in Balloons and Captions on the page. Delete All Text on Page 

deletes all the text in Balloons and Captions on the page. Lettering elements are not affected by these three 

actions. Text can also be made bigger or smaller here. 
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Panel Details: The Panel Details lets you switch between rectangular and polygonal panels.  

Irregular: Panels are typically rectangular in shape but you can create irregular shaped panels by 
checking this box. When checked the eight corners of the panel can be positioned independently allowing 
you to reshape the panel as needed. You can change the number of sides of the panel from a minimum of 
3 (for triangular panels) to a maximum of 8 (for complex polygons). If you uncheck the box the panel will 
be converted back to a rectangle that is sized to the maximum bounds of the irregular panel.  
 

Adding images: When you find an image you like, you can grab it and drag it into a Panel. You can always just 

drag it on the page by itself if you want, but a panel will allow you to clip the image so you only see the parts 

you like. When placing the image in a panel, you need to move the mouse cursor over the panel itself, so when 

you release your picture it will be 'put inside' the panel. This is how you can control it if a Panel clips the sides 

of a photo off — if your mouse cursor is inside the panel, then the photo will clip. TIP: If you can't get the right 

placement/ clipping, then try putting the photo down and picking it up from a different part. Once your image is 

placed in a panel, it will expand to make best use of the panel space. Now is the opportunity to make sure your 

image is placed exactly as you want it. 

 

Working with multiple images in a panel 

Multiple images may be placed into a single panel by holding down the 'Alt' key when dragging an image into a 

panel. Each image may have its own scaling, style, rotation and placement. You can work with each image by 

double clicking on a panel. Then, single click to select the image you want to work with. 

 

Manipulating image: An image can: 
- Be clipped at the edges of a panel, by making sure the mouse cursor is within the panels edges when you 

release your photo 

- Be rotated by grapping the purple rotate handle. Holding down shift will lock rotation into 90 degree angles — 

handy for changing landscape to portrait layout 

- Be rescaled on the fly by dragging the green selection circles 

- Be flipped on either axis by utilizing the Image Attributes in the Details view 

- Have its own independent frame and shadow 

 

TIP: If you have many overlapping windows and it becomes difficult to grab your photo, try to grab it by the 

semitransparent circular handle in the middle. This will always allow you to drag. 

Comic Life 'locks' the image into a panel after you deselect it — this makes it easy for you to move you new 

panel and image around as a unit. But if you decide you want to edit your image (or delete the image from a 

panel), just remember to DOUBLE CLICK. This will select the actual image inside a panel, and now you can 

re-size, rotate etc until you are happy. Then just click in some space to deselect the photo, and it will lock back 

in. Notice the differences between a clipped image, and unclipped image within a Panel. 

 

 

 

 

Image Filtering: Comic Life provides a number of filtering options to help you turn your photos into realistic 

comic illustrations. There are a wide variety of options from converting images to black & white to giving them 

a painted look. All these filters are available from the Image Details tab (or you can use the drop-down Style 

option in the Toolbar).  
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To access the Details tab, select an image (if the image is in a panel you'll need to double-click on the panel to 

select the image, making sure the image you want to apply the effect to is selected): And make sure the Details 

tab is visible: Click on the filters popup menu to see the list of available filters:  

Try out some of the other filters in the menu to see what effect they have — you'll find there is a wide variety. 

Tip: If you update the Default style to have a filter then all images with the Default style (and any new images) 

will all be filtered in the same way. The Invert checkbox inverts the colors in the image (after any filter has been 

applied) for a photo negative effect.  

The Colorize checkbox applies the colour shown in the colour well to the image — you can get sepia like 

effects with this — or any other colour tone you might like. Again, the colourize is applied after any selected 

filter (and after invert, if that is selected).  

 

Editing Balloon text: To edit the text in the Balloon double-click on the Balloon and the 

text will become editable. Note: When a Balloon is selected you can also hit "Enter" on 

your keyboard to begin editing. You can change the font, point-size and characteristics of 

the text using the Format->Font menu.  

Text in Balloons is center justified (aligned) by default. This follows the standard comic convention, but you 

can also left justify and right justify your text by selecting it and choosing Format->Text. Once 

you're done editing, hit the "Enter" key or use the mouse to click outside the editing area. Your 

changes will be shown in the Balloon.  

 

 

Resizing a Balloon: To resize a Balloon select it and drag any of the green resize handles on the perimeter of 

the Balloon.  

Moving a Balloons body: To move a Balloon, simply select it and drag from within the Balloon. The 
Balloon will follow your mouse.  

Moving the tail: Once the Balloon text is appropriately sized and positioned, position the tail so that the 
Balloon is associated with the right person. Mouse over the Balloon and you'll see a marker handle show 
up that indicates the place to click. Click on this handle and drag the tail into place. 
 

Moving a Balloon and its tails: A Balloon is normally anchored by its tail in a Panel. To move the Balloon and 

its tails in a single move, click and drag the 'move handle', which appears 

whenever you move over a Balloon. 

 

Add an additional Balloon: To add another Balloon to an 

existing Balloon simply drag the extension Balloon from the 

well and drop it on a Balloon that needs extending. The new 

Balloon is automatically connected to the existing Balloon and displayed as the same type as the original 

Balloon.  

 

Adding Additional Tails: Sometimes you may like to have more than one person saying the same words at the 

same time, for example a crowd of people singing 'Happy Birthday'. You can add additional tails to a single 

Balloon by clicking on the  '+' button attached to the tail of each Balloon. You may then move the tails where 

you need. 
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1. 2. 3.  

Text Margin: If the text is too close to the edges of the Balloon (or not close enough) you can adjust the 

margins by assigning new values to the Horizontal (H) and Vertical (V) margins. Style properties: Use the 

Style popup menu to pick a different style, or simply experiment until you create a style you like. If you have 

made a variation to the selected style, then a Pencil appears next to the style name. Your element is now unique! 

Add and Edit a Caption: To add a Caption, drag a Caption from the element palette to wherever you 
want it on the page. To edit a Caption, double click it. Also you can select it and hit the "Enter" key. The 
Caption text becomes editable and is selected. Type in whatever words you would like. You can change 
the text formatting by using the Format->Font and Format->Text menu items. Caption text can have any 
justification or font setting you need. 
 

Caption Details: The Details view shows you the adjustable margins between the text and the Caption outline 

if needed. You can also choose the style for the Caption or override the Style Attributes if necessary.  

Text Margin: If the text is too close to the edges of the Caption (or not close enough) you can adjust the 
margins by assigning new values to the Horizontal (H) and Vertical (V) margins.  

Clip: Normally, Captions overlap edges of panels. By checking 'CLIP', you can make a Caption clip to stay 
inside the panel by default, which is the more 'traditional' approach.  

Working with Lettering: Lettering in Comic Life covers two compositional elements: Titles and Sound 
Effects. Comic titles frequently involve warped Lettering (for example the Superman logo) or interesting 
fills, outlining and shadows. Comic sound effects (for example "POW", "ZAP", "BOING", etc.) are always 
warped and filled with color. Lettering elements let you accomplish both with ease.  

Editing Lettering: If you would like to change the font or the text of the Lettering, simply double click on 
it and the Lettering dialog will reappear so you can adjust the text and font upon which the Lettering is 
based. Once you click the "Place Lettering" button again, the new text is warped to fit the current 
Lettering outline. To move the lettering: Simply click and drag the Lettering to the appropriate location.  

Resizing Lettering: Resizing Lettering is where the fun begins. Dragging the corner resize handles warps 
the Lettering to fit the new shape. You can add a lot of drama to a sound effect by dragging out its top two 
corner handles. To bend the Lettering use the top and bottom center handles. These are special handles 
that gently bend the letters so they curve to fill the new space. These center handles retain their relative 
position between their respective corner handles so that adjusting the corners does not interfere with the 
curve that you've applied.  

Scaling Lettering: If you like the general shape of your Lettering, but want to change its dimensions, then you 

need to use the re-scaling handles. Click on the text to select it, and once it is selected, click on the text again. A 

box with a set of square green handles will appear which you can use to re-scale your text. 
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Rotating Lettering: You can rotate a Lettering element to any angle by selecting the element and 
dragging the rotate handle around. Holding down shift locks the angle to the nearest 90° angle. 

Lettering Details: The Lettering Details offers a few extended features for Lettering. 

Horizontal Spread: Increases or decreases the horizontal space between the individual letters in the 
Lettering. Note that this has little or no impact when the letters are aligned vertically.  

Vertical Spread: Increases or decreases the vertical space between the individual letters in the Lettering. 
Note that this has little or no impact when the letters are aligned horizontally. 

Skew: Skew lets you rotate the baseline of the Lettering without rotating the letters (for a stair-step 
effect) — providing a useful dynamism without impacting legibility. 

Stagger: The stagger buttons cause the individual letters to be alternately shifted 
up and down or left and right. This gives the Lettering a jumbled effect for added 
impact. You can keep clicking either of the buttons to increase the effect. Use Edit-
>Undo to revert back.  

Join character outlines: Sometimes you'll want the characters to be displayed 
individually and have the outlines of each overlap. Other times you'll want the letters 
to be joined neatly together. Checking this option draws the Lettering as a single 
graphic object so that a gradient fill is drawn across all the letters, outlines are 
merged (where they overlap) and the shadow (if any) is beneath all the characters.  
 

Working with Styles: Styles are a handy way to make uniform changes to the look of your comic: These are all 

editable in a single place — the Style Attributes in the Details tab. All the styles settings in a comic are called a 

"stylesheet". You can save and load stylesheets independently from a comic — allowing you to easily create 

multiple comics with a standard look. If you want ALL elements to be created in a particular style then Update 

the 'Default' style. 

 

Creating a new style 

 Create a new comic 

 Place an element (for example, a panel) on the page  

 Bring up the Details interface by choosing View->Show Details or by clicking on the Details" tab 

 All the attributes for the object, and the style for the object are displayed . 

 Change the color and watch the panel background color change. Notice now the pencil icon next to the 

style name.  This shows there is a variation to the style  

 

Press the 'Save As... +' button, and a pop-up menu asks you to name your new style. 

Let’s call it, "Big Green".  Click OK 

You can now use this style for other elements 
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Updating a style: Create a new Panel by dragging it out from the Library  

 

Now set its style to the new “Big Green” style we just created by choosing it in Style Attributes (In Details). 

You can see the style we just made 

 

Make a change to the panel, for example, make the frame thicker 

Now there is pencil icon next to our style. That means you have made a variation 

If you like the change, and want all elements with the same style to change as well, click 

"✓ Update" The pencil icon badge now disappears. Also, our first panel now has a thick border 

as well — as it uses the same style  

 

Reverting to a style 

At any point you can revert back to the original style chosen by selecting 'Revert'. A popup menu will remind 

you that you will lose your changes to the style — to prevent this you should update the current style or create a 

new style. 

 

 

Panel Stylesheet 

Style menu: Select the panel style you want, or make changes to the style as a variation. Select 'Update' to 

change the style itself to match your variation, create a new style using 'Save As...' which you can use later on 

other elements. 'Revert' will return to the original style selected. 

 

Background: Optionally fill the background of the panel with the selected color. 

 

With Gradient: Optionally fill the background of the panel with a color gradient beginning with the 

Background color and ending with the Gradient color. The circular control to the right sets the actual gradient. 

 

Frame: Optionally draw a frame around the panel with the specified width. The Type popup lets you specify a 

shape for rectangular panels. Some shapes have special shapes such as bevels that can be adjusted with the 

Factor field. 

 

Shadow: Optionally draw a shadow behind the panel with the specified color, Blur radius and Offset. 

 

Caption Stylesheet 

Style menu: Select the Caption style you want or simply make some changes as a variation to the style. You 

can 'Update' the style (which affects all elements in this style), create a new style using 'Save As... +', or simply 

'Revert' back to the original style. 

Background: Optionally fill the background of the Caption with the selected color. 

 

With Gradient: Optionally fill the background of the Caption with a color gradient beginning with the 

Background color and ending with the Gradient color. The circular control to the right sets the actual gradient. 

 

Frame: Optionally draw a frame around the Caption with the specified width. The Type popup lets you specify 

a shape for rectangular panels. Some shapes have special shapes such as bevels that can be adjusted with the 

Factor field. 

 

Shadow: Optionally draw a shadow behind the Caption with the specified color, Blur radius and Offset. 
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Font: Specify the default font and font color for new Captions. The font will change when a style is manually 

selected in the style menu. You are not restricted from changing the font with the Font Panel once the Caption is 

created. 

 

Balloon Stylesheet 

Style menu: Select the Balloon style you want or simply make some changes as a variation to the style. You 

can 'Update' the style (which affects all elements in this style), create a new style using 'Save As... +', or simply 

'Revert' back to the original style.  

 

Background: Optionally fill the background of the Balloon with the selected color. 

 

With Gradient: Optionally fill the background of the Balloon with a color gradient beginning with the 

Background color and ending with the Gradient color. The circular control to the right sets the actual gradient. 

 

Frame: Optionally draw a frame around the Balloon with the specified width. You can also choose to have 

straight tails instead of the normal 'curved' look. 

Shadow: Optionally draw a shadow behind the Balloon with the specified color, Blur radius and Offset. 

Font: Specify the default font and font color for the Balloon. The font will change when a style is manually 

selected in the style menu. You are not restricted from changing the font with the Font Panel once the Balloon is 

created. 

 

Image Stylesheet 

Style menu: Select the image style you want or simply make some changes as a variation to the style. You can 

'Update' the style (which affects all elements in this style), create a new style using 'Save As... +', or simply 

'Revert' back to the original style. 

 

Filter: Optionally filter the image to add an effect. 

 

Invert: Optionally invert the colors in the image to give a "negative" effect. 

 

Colorize: Optionally convert the image into monochrome based on the color in the color well. 

 

Frame: Optionally draw a frame around the image with the specified width. 

 

Shadow: Optionally draw a shadow behind the image with the specified color, Blur radius and Offset. 

 

Lettering Stylesheet 

Style menu: Select the Lettering style you want or simply make some changes as a variation to the style. You 

can 'Update' the style (which affects all elements in this style), create a new style using 'Save As... +', or simply 

'Revert' back to the original style.  

 

Fill: Optionally fill the background of the Lettering with the selected color. 

 

Gradient: Optionally fill the background of the Lettering with a color gradient beginning with the Background 

color and ending with the Gradient color. The circular control to the right sets the actual gradient. 
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Outline: Optionally draw a border around the Lettering with the specified color. The Count field specifies how 

many borders should be drawn around the Lettering. If there is more than one border around the Lettering the 

outline color is alternated with the Alt color. The Width specifies how thick the border should be. 

 

Shadow: Optionally draw a shadow behind the Lettering with the specified color, Blur amount and Offset. 

 

Font: Specify the default font for new Lettering elements. This font can be changed on the Lettering creation 

dialog. 

 

Page Stylesheet 

The page stylesheet is much like every other element's stylesheet. However it does have a few unique points. To 

select the page, you need to click on some empty part of the page. The details tab will show PAGE 

ATTRIBUTES and STYLE ATTRIBUTES. The page itself has no Page Attributes (this is handled by File-> 

Page Format), so we will focus on the Style Attributes. 

Style Menu: Select the Page style you want or simply make some changes as a variation to the style. You can 

'Update' the style (which affects all elements in this style), create a new style with 'Save As... +', or simply 

'Revert' back to the original style. For simplicity, we recommend that you simply update the default style once 

you are happy with the page numbering style. From then on, all new pages will look like this one.  

 

Fill: Optionally fill the page with the selected color. 

Gradient: Optionally fill the page with a color gradient beginning with the Background color and ending with 

the Gradient color. The circular control to the right controls the gradient angle. 

 

Page Number: Optionally draw a page number on the page. You can choose which edge the page number 

aligns to with the popup menus, and use Inset to move the page number closer or further away from the page 

centre. 

 

Backdrop: The backdrop is like a panel for your page number. It can be set to a caption style, and have its own 

vertical size, horizontal size, and rotation. For more control over this create a special caption style for page 

number backdrops. To achieve this do the following:  

Create a caption style using an available caption 

If you don't have one drag a temporary one onto the comic to get access to the caption styles editor 

In the Caption Styles Attributes tweak the settings till you get something you like. 

Click on "Save As" to create a new caption style for page numbers. 

Delete the temporary caption if you created one. 

Deselect everything on the page to get back to the page attributes (probably there already).  

Select the new caption style in the Caption Style menu. 

Click Update to get all pages to use this style (assuming you're modifying the Default style). 

Font: Specify the font, size, and color for Page Numbers.  

 

Publishing: The ultimate product of Comic Life is a published comic — the application lets you publish in a 

variety of forms which is a major reason for some of the unusual page formats that are supported. You can print 

your comic using the standard print dialog — but you can also export your comic as HTML or an AVI movie. 

This section explores all these options.  

 

Printing: If you intend to print your comic you will get best results by choosing a page format that matches 

your printer. Comic Life comes with a wide selection of standard page sizes. Once your comic is complete you 

can print it simply by choosing File->Print... and clicking "OK".  
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Note: Don't be alarmed if it seems to take a while to print.. Comic Life uses your high-resolution images for 

best results, and this can slow down the printing process. 

If you want a quick proof of your comic make sure the "Low-Res Proof" option is selected in the Comic Life 

settings of the Print dialog. The printer will use the screen resolution images (~ 72 dpi) for faster printing. You 

can also lower the quality setting using the Properties panel in the Print dialog (if supported by your printer). 

Note that this setting is remembered while the application is running so if you need a final proof then you must 

uncheck this option. 

Export to HTML: Comic Life can turn your comic into a convenient web presentation with the Export to HTML 

feature. To access this feature choose "File->Export to HTML...". On the export dialog enter the name and 

location of the folder that will hold the HTML files and images. You can also choose a theme for the frame that 

will surround the comic and the quality of the JPEG images. Click on the "Save" button to create the HTML 

files.  

 

Export to Movie: Comic Life can turn your comic into an AVI movie for use as part of a multimedia project. 

The AVI movie can be imported into a number of Windows movie editing software for further editing.  

To export an AVI movie choose File->Export to Movie... In the export dialog choose a name and location for 

the movie as well the quality of the JPEG images that form the frames of the movie and the duration that each 

page will be presented. Click on "Save" when you are ready to start the process. 

 

Email Comic Button: With a single click you can email a multiple page comic, as a series of JPG files to your 

friends and family. Choose an 'Email subject', and then press 'Export' and a new email message will be opened 

for you (in your default email client) with each comic page attached as cross-platform JPG images. You can 

now write the body of your email and send to your recipient of choice. Easy! 

Note: 'Email this Comic' may not work with all email clients. 

Advanced Lettering -Fitting words in a Balloon: 
Once you've made a few comics or even added a few Balloons you'll notice that sometimes the words in a 

Balloon naturally fit the available space and other times there is a lot of empty space in the Balloon — and the 

Balloon is taking up too much room. For example:  

 
In this example, the words do not form an outline that matches the Balloon shape and the result looks bad. 

There are a couple of approaches to solve this problem and usually a combination of the two will get the desired 

result.  

The first approach is to adjust the shape of the Balloon to better fit the words. Stretching this Balloon out 

horizontally will definitely help the words to fit. If you have room in the panel try resizing the Balloon to 

different Balloon shapes to best fit the words.  

The next approach is to adjust the line breaks in the words to force the text to make an oval shaped outline. For 

example a line break after "THIS IS" will make sure that not too much text is at the top of the Balloon. Continue 

adding line breaks until the text makes a pleasing oval or circular outline.  
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The final approach is to change the words. If you can't get the existing words to fit in a pleasing way try 

choosing different words. Balloons benefit from small words. Long words make it difficult to get the shape you 

need — unless, of course, that word just happens to land at the widest point of the Balloon. After applying these 

techniques this is what a well laid out Balloon would look like:  

Options 

Comic Life's Options (View > Options...) let you specify some preferences that you 

might like in Comic Life — giving you greater control and customization over the 

application. These include, the ability to set:  

Default Page Format — set that preferred page size of your comic projects 

Custom Size (in points) — use this if the page size you need isn't included in the drop-down menu 

Orientation — choose from either Landscape or Portrait page orientation for new comics 

Default Stylesheet — choose from one of the built-in Stylesheets or one of your own (if you have created any) 

for new comics 

WYSIWYG image filtering — when this option is turned on it preserves what you see when you apply the 

effects with Comic Life - in other words, it is What You See Is What You Get when you export your comic. It 

keeps your filtered images at a 72 dpi regardless of your export settings that you have applied. This is why at 

the larger dpi export settings your normal photos will look fine, but the photos with filters will look pixelated. 

Remove the tick if you do not want the pixelation. Please note: removing the tick will cause the filter to look 

less pronounced 

Play sounds while editing — want to make comics but need to be quiet? You can turn of the infectious sounds 

by checking this option 

Check for newer version at launch — you can also choose whether Comic Life checks for new versions when it 

is launched. 

 
 

NB. These notes are a compilation of the online help notes. For more detail or information click the help icon 

on the programme and search. 


